"unable to remove Cassandra data points"

#1

I am trying to remove Measurement data, but it fails.
First, I tried to remove the record using a MapReduce job that worked perfectly in other tenant/tag environment, but here it failed with the following exception.

errorMsg: Error removing obj with id ‘950063320-0001_101_kilowatt_hour#LQ3X5HO’ of type ‘Measurement’: c3.love.exceptions.C3RuntimeException: wrapped NullPointerException at c3.engine.database.UpsertTask.addMetricInval (UpsertTask.java:762) from action Measurement.removeAll from env_server.j

Then, I fetched the record and it looks ok, but when I try to get and remove it, it fails with below NullPointer exception.

{
“type”: “Measurement”,
“id”: “950063320-0001_101_kilowatt_hour#LQ3X5HO”,
“version”: 1,
“parent”: {
“id”: “950063320-0001_101_kilowatt_hour”
},
“start”: “2001-03-13T00:00:00.000Z”,
“end”: “2001-04-12T00:00:00.000Z”,
“quantity”: {
“value”: 1077
}
}

m = Measurement.get(‘950063320-0001_101_kilowatt_hour#LQ3X5HO’);
m.remove();

C3.client.ActionError {name: “ActionError”, message: “wrapped NullPointerException”, error: C3.t…s.Obj, stack: “Error: wrapped NullPointerException↵ at new C3.…267:20), :5:22)↵ at :1:3”}error: C3.typesys.Obj {id: “193.98”, key: “c3.love.exceptions.C3RuntimeException_wrapIt”, cause: C3.t…s.Obj, template: “{}”, parameters: Array(3), …}message: "wrapped NullPointerException"name: "ActionError"stack: "Error: wrapped NullPointerException↵ at new C3.client.ActionError .

Any ideas what could be the issue?

#2

I was able to remove the measurment records with same code, after setting AsyncProcessingDisabled = true in TenantConfig.