Trying to install the C3 provisioner

#1

Hi,
On win10 I am trying to install the c3-prov (latest) following this guide:
https://github.tools.digital.engie.com/GBSEngieDigitalC3COE/engieApps/blob/master/documentation/c3_developer_guide.md

the error has something to do with NodeJS I think.

all in the error, still can’t figure out.

Trying with both versions: the current stable and I tried using an earlier version of node v7.3.0.
I also downgraded npm to an earlier version: npm install -g npm@3.10.7

Any suggestions ?

λ c3-prov install
Detecting Node.js installation…
Node.js v8.11.3 detected.
Removing C:\Users\HR5537\AppData\Local\c3\nodeapps\prov …
Installing dependencies at C:\Users\HR5537\AppData\Local\c3\nodeapps\prov
npm WARN deprecated graceful-fs@3.0.6: please upgrade to graceful-fs 4 for compatibility with current and future versions of Node.js
npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
npm WARN deprecated minimatch@0.2.14: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
(node:1348) MaxListenersExceededWarning: Possible EventEmitter memory leak detected. 11 error listeners added. Use emitter.setMaxListeners() to increase limit
(node:1348) MaxListenersExceededWarning: Possible EventEmitter memory leak detected. 11 error listeners added. Use emitter.setMaxListeners() to increase limit
(node:1348) MaxListenersExceededWarning: Possible EventEmitter memory leak detected. 11 error listeners added. Use emitter.setMaxListeners() to increase limit
(node:1348) MaxListenersExceededWarning: Possible EventEmitter memory leak detected. 11 error listeners added. Use emitter.setMaxListeners() to increase limit
(node:1348) MaxListenersExceededWarning: Possible EventEmitter memory leak detected. 11 error listeners added. Use emitter.setMaxListeners() to increase limit
(node:1348) MaxListenersExceededWarning: Possible EventEmitter memory leak detected. 11 error listeners added. Use emitter.setMaxListeners() to increase limit
(node:1348) MaxListenersExceededWarning: Possible EventEmitter memory leak detected. 11 error listeners added. Use emitter.setMaxListeners() to increase limit
(node:1348) MaxListenersExceededWarning: Possible EventEmitter memory leak detected. 11 error listeners added. Use emitter.setMaxListeners() to increase limit
(node:1348) MaxListenersExceededWarning: Possible EventEmitter memory leak detected. 11 error listeners added. Use emitter.setMaxListeners() to increase limit
(node:1348) MaxListenersExceededWarning: Possible EventEmitter memory leak detected. 11 error listeners added. Use emitter.setMaxListeners() to increase limit
C:\Users\HR5537\AppData\Local\c3\nodeapps\prov
±- ansimd@0.2.0
| ±- marked@0.3.19
| -- unescape-html@1.0.0 +-- archiver@0.14.3 | +-- async@0.9.2 | +-- buffer-crc32@0.2.13 | +-- glob@4.3.5 | +-- lazystream@0.1.0 | +-- lodash@3.2.0 | +-- readable-stream@1.0.34 | | +-- core-util-is@1.0.2 | | +-- isarray@0.0.1 | |– string_decoder@0.10.31
| ±- tar-stream@1.1.5
| | ±- bl@0.9.5
| | ±- end-of-stream@1.4.1
| | -- xtend@4.0.1 |– zip-stream@0.5.2
| -- compress-commons@0.2.9 | +-- crc32-stream@0.3.4 |– node-int64@0.3.3
±- chokidar@1.0.1
| ±- anymatch@1.3.2
| | ±- micromatch@2.3.11
| | | ±- arr-diff@2.0.0
| | | | -- arr-flatten@1.1.0 | | | +-- array-unique@0.2.1 | | | +-- braces@1.8.5 | | | | +-- expand-range@1.8.2 | | | | |– fill-range@2.2.4
| | | | | ±- is-number@2.1.0
| | | | | ±- isobject@2.1.0
| | | | | | -- isarray@1.0.0 | | | | | +-- randomatic@3.0.0 | | | | | | +-- is-number@4.0.0 | | | | | | +-- kind-of@6.0.2 | | | | | |– math-random@1.0.1
| | | | | -- repeat-string@1.6.1 | | | | +-- preserve@0.2.0 | | | |– repeat-element@1.1.2
| | | ±- expand-brackets@0.1.5
| | | | -- is-posix-bracket@0.1.1 | | | +-- extglob@0.3.2 | | | +-- filename-regex@2.0.1 | | | +-- is-extglob@1.0.0 | | | +-- is-glob@2.0.1 | | | +-- kind-of@3.2.2 | | | |– is-buffer@1.1.6
| | | ±- object.omit@2.0.1
| | | | ±- for-own@0.1.5
| | | | | -- for-in@1.0.2 | | | |– is-extendable@0.1.1
| | | ±- parse-glob@3.0.4
| | | | ±- glob-base@0.3.0
| | | | | ±- glob-parent@2.0.0
| | | | | -- is-glob@2.0.1 | | | | +-- is-dotfile@1.0.3 | | | |– is-glob@2.0.1
| | | -- regex-cache@0.4.4 | | |– is-equal-shallow@0.1.3
| | | -- is-primitive@2.0.0 | |– normalize-path@2.1.1
| | -- remove-trailing-separator@1.1.0 | +-- arrify@1.0.1 | +-- async-each@0.1.6 | +-- glob-parent@1.3.0 | |– is-glob@2.0.1
| ±- is-binary-path@1.0.1
| | -- binary-extensions@1.11.0 | +-- is-glob@1.1.3 |– readdirp@1.4.0
| ±- graceful-fs@4.1.11
| -- minimatch@0.2.14 | +-- lru-cache@2.7.3 |– sigmund@1.0.1
±- colors@1.0.3
±- commander@2.7.1
| -- graceful-readlink@1.0.1 +-- glob@5.0.3 | +-- inflight@1.0.6 | |– wrappy@1.0.2
| ±- inherits@2.0.3
| ±- minimatch@2.0.10
| | -- brace-expansion@1.1.11 | | +-- balanced-match@1.0.0 | |– concat-map@0.0.1
| -- once@1.4.0 +-- less@2.5.0 | +-- errno@0.1.7 | |– prr@1.0.1
| ±- graceful-fs@3.0.6
| ±- image-size@0.3.5
| ±- mime@1.6.0
| ±- mkdirp@0.5.1
| | -- minimist@0.0.8 | +-- promise@6.1.0 | |– asap@1.0.0
| ±- request@2.87.0
| | ±- aws-sign2@0.7.0
| | ±- aws4@1.7.0
| | ±- caseless@0.12.0
| | ±- combined-stream@1.0.6
| | | -- delayed-stream@1.0.0 | | +-- extend@3.0.2 | | +-- forever-agent@0.6.1 | | +-- form-data@2.3.2 | | |– asynckit@0.4.0
| | ±- har-validator@5.0.3
| | | ±- ajv@5.5.2
| | | | ±- co@4.6.0
| | | | ±- fast-deep-equal@1.1.0
| | | | ±- fast-json-stable-stringify@2.0.0
| | | | -- json-schema-traverse@0.3.1 | | |– har-schema@2.0.0
| | ±- http-signature@1.2.0
| | | ±- assert-plus@1.0.0
| | | ±- jsprim@1.4.1
| | | | ±- extsprintf@1.3.0
| | | | ±- json-schema@0.2.3
| | | | -- verror@1.10.0 | | |– sshpk@1.14.2
| | | ±- asn1@0.2.3
| | | ±- bcrypt-pbkdf@1.0.2
| | | ±- dashdash@1.14.1
| | | ±- ecc-jsbn@0.1.2
| | | ±- getpass@0.1.7
| | | ±- jsbn@0.1.1
| | | -- tweetnacl@0.14.5 | | +-- is-typedarray@1.0.0 | | +-- isstream@0.1.2 | | +-- json-stringify-safe@5.0.1 | | +-- mime-types@2.1.19 | | |– mime-db@1.35.0
| | ±- oauth-sign@0.8.2
| | ±- performance-now@2.1.0
| | ±- qs@6.5.2
| | ±- safe-buffer@5.1.2
| | ±- tough-cookie@2.3.4
| | | -- punycode@1.4.1 | | +-- tunnel-agent@0.6.0 | |– uuid@3.3.2
| -- source-map@0.4.4 |– amdefine@1.0.1
±- node-dir@0.1.6
±- node-xml-lite@0.0.3
| -- iconv-lite@0.4.23 |– safer-buffer@2.1.2
±- rimraf@2.3.2
| -- glob@4.5.3 +-- superagent@1.1.0 | +-- component-emitter@1.1.2 | +-- cookiejar@2.0.1 | +-- debug@2.6.9 | |– ms@2.0.0
| ±- extend@1.2.1
| ±- form-data@0.1.3
| | -- combined-stream@0.0.7 | |– delayed-stream@0.0.5
| ±- formidable@1.0.14
| ±- methods@1.0.1
| ±- mime@1.2.11
| ±- qs@2.3.3
| ±- readable-stream@1.0.27-1
| -- reduce-component@1.0.1 +-- toposort@0.2.12– underscore@1.8.2

npm WARN optional Skipping failed optional dependency /chokidar/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: fsevents@0.3.8
npm WARN enoent ENOENT: no such file or directory, open ‘C:\Users\HR5537\AppData\Local\c3\nodeapps\prov\package.json’
npm WARN prov No description
npm WARN prov No repository field.
npm WARN prov No README data
npm WARN prov No license field.
Nombre de paramètres non valide
Nombre de paramètres non valide
npm WARN optional Skipping failed optional dependency /chokidar/fsevents:
npm WARN notsup Not compatible with your operating system or architecture: fsevents@0.3.8
npm WARN enoent ENOENT: no such file or directory, open ‘C:\Users\HR5537\AppData\Local\c3\nodeapps\prov\package.json’
npm WARN prov No description
npm WARN prov No repository field.
npm WARN prov No README data
npm WARN prov No license field.

Many thanks.

0 Likes

#2

Try with older versions:

$ node -v
v6.12.3
$ npm -v
5.6.0

On a side note, when you download the provisioner from your environment, e.g.

curl -O https:/vanity-url/static/nodejs-apps/prov/provisioner.zip -u "$C3_USER":"$C3_USER_PASSWORD"

the .zip file is for windows, and the .tar.gz file is for linux/osx

0 Likes