Tiles urls on Dashboard not loading properly when clicked


#1

I’ve a dashboard page with the following tiles

            {
                "id": "EUIoverTimeCombinedTile",
                "component": "EnergyManagement.EUIoverTimeCombined",
                "masterTemplate": false,
                "template": "EnergyManagement.EUIMetricTile",
                "renderTo": "#TopSquare1",
                "height": 160,
                "title": "{~EnergyManagement.Tile1.title~}",
                "titleAlign": "center",
                "titleUrl": "/energymgt/analyzeEnergy?dashboardFilter={{params.dashboardFilter}}&dashboardMetric=CombinedEUI",
                "box": true
            },
            {
                "id": "EUIoverTimeElectricityTile",
                "component": "EnergyManagement.EUIoverTimeElectricity",
                "masterTemplate": false,
                "template": "EnergyManagement.EUIMetricTile",
                "renderTo": "#TopSquare2",
                "height": 160,
                "title": "{~EnergyManagement.Tile2.title~}",
                "titleAlign": "center",
                "titleUrl": "/energymgt/analyzeEnergy?dashboardFilter={{params.dashboardFilter}}&dashboardMetric=ElectricityEUI",
                "box": true
            },
            . . .

When the user clicks on those tiles he’s forwarded to AnalyzeEnergy, the url has correct metric name however the selected metric (in analytics) is always set to ‘CombinedEUI’. I have to refresh the page to get the right original metric been selected and displayed.

How could I force the right metric to be selected without having to refresh the page?


#2

You can try setting the "cache": false parameter on the UIDataSource that is using the dashboardMetric parameter


#3

We were able to get this working on NYPA:

Few things to do:

  1. Check if the configured metric exists on Analyze Energy. Sometimes they dont. You can check the metric access group type for the list of analytics in AE

  2. Configure the link per the below format:
    “titleUrl”: “/energymgt/analyzeEnergy?dashboardFilter={{params.dashboardFilter}}&dashboardMetric=billedElectricitySpend#”

  3. Make sure cache is disabled on the analyze energy page: