Provisioning Error


#1

I get the following error while provisioning. I haven’t seen anything like this before and it doesn’t really give me any insight into what the error may be. I haven’t changed package.json

[3m/nick] No such dependency ‘foundation’ in package.json can be found in package ‘inventoryAnalysis’
[3m/nick] No such dependency ‘tools’ in package.json can be found in package ‘inventoryAnalysis’
[3m/nick] No such dependency ‘uiFramework’ in package.json can be found in package ‘inventoryAnalysis’
[3m/nick] No such dependency ‘userAdmin’ in package.json can be found in package ‘inventoryAnalysis’
[3m/nick] No such dependency ‘energyManagement’ in package.json can be found in package ‘inventoryAnalysis’
[3m/nick] Created 274.79Kb ZIP of one package in 0.1s
[3m/nick] Server Warnings:
{fileUrl:“meta://base/uiDesigner/ui/designer/templates/template/Overlay.c3ml”,lineNum:0,colNum:0,severity:“WARNING”,message:“transformed content is null”}
{fileUrl:“meta://base/uiDesigner/ui/designer/templates/Controller.c3ml”,lineNum:0,colNum:0,severity:“WARNING”,message:“transformed content is null”}
[3m/nick] Server Errors: (2018-04-11T10:12:06.587-05:00)
{fileUrl:“meta://3m/inventoryAnalysis/package.json”,lineNum:0,colNum:0,severity:“ERROR”,message:"[Cause] java.lang.NullPointerException\n[Message] wrapped NullPointerException\n\n at c3.engine.database.DbEngineListenerMethods.lambda$validateRefFieldsForType$1 (DbEngineListenerMethods.java:120)"}
{fileUrl:“meta://3m/inventoryAnalysis/package.json”,lineNum:0,colNum:0,severity:“ERROR”,message:"[Cause] java.lang.NullPointerException\n[Message] wrapped NullPointerException\n\n at c3.engine.database.DbEngineListenerMethods.lambda$validateRefFieldsForType$1 (DbEngineListenerMethods.java:120)"}
Time taken: 0m 39.604s


#2

I had never seen this either but was able to reproduce it just now by chance (i’m working on a better error message).

The issue is that you have a field with a reference to a type that doesn’t exist. Look through your recent changes and you will find either a new field was added (without the corresponding type) or a type was removed (without removing the field which references it)


#3

Fantastic! I will look through for it - thanks for working on a better error message - that would be great!