How to provision seed data for FileTimedDataPoint


#1

I am trying to provision seed data for a type that mixes FileTimedDataPoint type. The provision was successful however I am not able to find the data on the Platform. I think there is a potential that it is a type of FileTimedDataPoint so I probably need to throw the data to S3. Any suggestion how to do this locally on my docker environment?


#2

I am running into a similar problem. I have a FileTimedDataPoint type and a metric defined on that type which is being evaluated in a test. It appears that the default file system for storing FileTimedDataPoint types if S3. However, developing locally and running c3server on docker, I get the following error:

failure=ActionError: c3.love.exceptions.C3RuntimeException: c3.love.exceptions.C3RuntimeException: MetricEngine error : c3.love.exceptions.C3RuntimeException: Error c3.love.exceptions.C3RuntimeException: AwsS3Client exception: The AWS Access Key Id you provided does not exist in our records. (Service: Amazon S3; Status Code: 403; Error Code: InvalidAccessKeyId; Request ID: F8EC1ACC54DB008D; S3 Extended Request ID: oXTHrsbUfdEvyGITOV8jOXUhQYOlTdeI9CNoTBAlii4ftSgMmxt9A2uOczhYSsVNwRMOtRH7r8A=)
errorCode="InvalidAccessKeyId"; errorType="Client"; requestId="F8EC1ACC54DB008D"; serviceName="Amazon S3"; httpStatusCode="403"

How can I configure my local docker to talk the local file system and not to S3?


#3

You can configure default file system through the FileSystemConfig but you should be able to send files to local file system even if your default file system is set to S3.


#4

@mehdi.maasoumy Do what @tony.li suggested make default file system to c3fs as below

s = FileSystemConfig.make().getConfig();
s.default = 'c3fs';
s.setConfig(ConfigOverride.TAG);
s.evictFromCache();

way to check if FileSystem is set to what you simply do this

FileSystem.inst().isC3() // should return true
FileSystem.inst().isS3() // should return false

Also I think you still might need to do a restart in 7.8 before running the above commands to verify if the FileSystem is configured correctly.

Again I am still not sure what provisioning has to do with the FileTimedDataPoint error. will need to look at stack trace.


#5

Thanks @garrynigel! That worked.