How to disable (temporarily) an Analytic


#1

I would like to disable a specific Analytic and the underlying DFEs for some time.

I suspect I can do the following:

  • Remove the analytic + DFE definitions from source code
  • provision/deploy
  • refresh metricDeps via a tag rebuild
  1. Can someone please confirm or add steps I missed?

  2. It seems cumbersome (especially if I want to use that Analytic again later), is there a more temporary solution, i.e. a config somewhere? (In my mind, if we could remove the appropriate metric dependencies, that’d do the trick, but I am open to other ideas)

Thanks!

PS: Additional notes if it’s helpful:

  1. I would like to avoid disabling the entire Queue.
  2. I also would like to avoid computing the DFE leading to that Analytic, as one of them is pretty computationally intensive.

Useful TenantConfig keys
#2

You can enable certain analytics by setting the “ACE-AnalyticWhitelist” tenant tag.

e.g.

TenantConfig.upsert({"id": "ACE-AnalyticWhitelist", value:"Analytic1, Analytic2..."})

Here’s the small doc from AnalyticsContainer.c3typ
ACE-AnalyticWhitelist : config to limit the analytics considered for execution. value is comma seperated list of analytic names.


Create a new Alert for high consumption - ServicePoint level
#3

@rohit.sureka The question was regarding disabling an analytic, but the ACE-AnalyticWhiteList is used to enable analytics. Must to clarify: does this mean that, if this record is present in TenantConfig, that only those analytics included will be able to run, and all others will be disabled?


#4

@akatkinson Unfortunately there isn’t a analyticblacklist. You are right. If this record is present in TenantConfig and the list is not empty or null, only analytics included will be able to run.


#5

Hi, I’m trying to disable Analytics except one. I launched from the console the command:
TenantConfig.upsert({"id": "ACE-AnalyticWhiteList", value:"ConsumptionTooHighServicePointAlert"})

But it seems not work, because I see that all the others Analytics are still executed…have I to execute some refresh or something else?

Thanks! Laura


#6

How do I disable all analytics? Can I use the tenant config and add a dummy entry?


#7

You have to modify the ACE-AnalyticGroups entry , listing the name of the Analytics that you want to ENABLE. Like :

TenantConfig.merge({id:“ACE-AnalyticGroups”, jsonValue:{
“All”: [“ANALYTIC_1”,“ANALYTIC_2”]
}})

To revert this configuration :

TenantConfig.merge({id:“ACE-AnalyticGroups”, jsonValue:{
“All”: “*”
}})


#8

Does this mean that there must be at least one active analytic? I get an error if I bind “All” to [].


#9

In 7.8.2,fixed bug with TenantConfig ACE-AnalyticWhitelist. If you list analytic Name “NONE”/dummy name, no analytic will be run. empty is treated as all valid.


#10

Good to know. I tried in 7.6 but it complained about an unknown name.


#11

@AlexBakic you must set “*” without “”, like

TenantConfig.merge({id:“ACE-AnalyticGroups”, jsonValue:{
“All”: “*”
}})


#12

Yes, but that means “enable all” whereas I want to disable all.
Thanks


#13

Ah ok, I didn’t understand. I don’t know if is possible, have you try to delete the jsonValue completely?