C3-prov Server Error - Version Conflict

#1

How to solve this error?

c3-prov tag -t airline -g engietraining5 -e https://airline5.c3-e.com -u userX -p passX
(node:12200) fs: re-evaluating native module sources is not supported. If you are using the graceful-fs module, please update it to a more recent version.
[airline/engietraining5] No such dependency ‘foundation’ in package.json can be found in package ‘airline’
[airline/engietraining5] No such dependency ‘uiFramework’ in package.json can be found in package ‘airline’
[airline/engietraining5] No such dependency ‘tools’ in package.json can be found in package ‘airline’
[airline/engietraining5] Created 0.1Mb ZIP of one package in 0.2s
[airline/engietraining5] Uploading package…
[airline/engietraining5] Starting provisioning…
[airline/engietraining5] Server Errors: (2017-01-16T20:28:46.460+01:00)
[Message] Write failed: Version Conflict. Update failed because of a version number conflict for type Tag
Version Conflict. Update failed because of a version number conflict for type Tag
Write failed: Version Conflict. Update failed because of a version number conflict for type Tag
Version Conflict. Update failed because of a version number conflict for type Tag
Time taken: 0m 27.822s

0 Likes

#2

Retry, simply retry, finally it works

0 Likes

#3

We believe there is a concurrency bug involving high provisioning loads on a single server. We will update when we have found the root of the issue. As you say, retrying should eventually succeed, given the root of the issue is concurrency related

0 Likes