ACE can not give streaming predictions


#1

I am writing ACE on 7.8.2. I tried to fire analytics using AnalyticsContainer.fireAnalytics and it worked. Then I update the measurement but it seems that the ACE has not been triggered. This is nothing in invalidation queue. I have already tried

TenantConfig.upsert({"id": "ACE-AnalyticWhitelist", value:"xxx"})

but it didn’t work.

Anyone who can tell me how to debug this?

Thanks.


#2

We are having a similar problem. fireAnalytics / refreshAnalytics works fine, but adding a new PointMeasurement does not trigger it. Interestingly, we discovered that adding a new PointPhysicalMeasurementSeries does trigger it, so it seems like it is just that very last step that is not being watched by the DFE. We are also not sure the best way to proceed debugging.


#3

After creating the new PointPhysicalMeasurementSeries, creating PointMeasurements for that new series seems to trigger it successfully. So I think the issue for me was that the pre-existing PointPhysicalMeasurementSeries weren’t being watched by the Analytic.


#4

Did you run a Tag rebuild to refresh the metricDeps?


#5

Not yet. Is there any document telling me how to write the rebuild? I am guessing we need to renormalize the data to trigger DFE, is that correct. I also find another command in the document

AnalyticsContainer.invalidateSources()

Will this be helpful in this situation?


#6

Not sure if this is what Louis is referring to, but one more thing that helped me was running

<Type>.refreshMetrics()
and
<Type>.refreshDeps({metricDeps:true })

where Type is the Type that your DFE is defined for.


#7

Tried both commands and they didn’t help give predictions. Did those make your analytics work?